$re = '/[\x{1F600}-\x{1F64F}]/u';
$str = '😄 sdsdfgfg';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);