using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(.*\) ?(?:: (.+))?";
string input = @" + Update () : void
+ KeyPress (key : int) : bool
+ KeyRelease (key : int) : bool
+ IsKeyDown (key : int) : bool
+ MousePress (button : int) : bool
+ MouseRelease (button : int) : bool
+ IsMouseDown (button : int) : bool
+ GetMouseX () : int
+ GetMouseY () : int
+ QuitRequested () : bool
+ GetInstance () : InputManager&
- InputManager ()
- ~InputManager ()
- mouseState : bool[6]
- mouseUpdate : int[6]
- keyState : ler abaixo
- keyUpdate : ler abaixo
- quitRequested : bool
- updateCounter : int
- mouseX : int
- mouseY : int
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}