$re = '/^([ -~]{1,})$/m';
$str = '//#define STR "QWERTYUIOPASDFGHJKLZXCVBNM"
//#define STR "qwertyuiopasdfghjklzxcvbnm123456789"
//#define STR "`~!@#$%^&*()-_+={[}]|\\\\;:i\\"\'<,>.?/"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);