#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([a-z0-9]+((?=\..+@.+\..+)[a-z0-9.]*@[a-z0-9]*\.[a-z0-9]*))$"
Local $sString = "nagarjuna.nag@vm.com" & @CRLF & _
"nagarjuna12.nag@vm.com" & @CRLF & _
"nagarjuna12.nag.some@vm.com" & @CRLF & _
"nagarjuna12.nag.somenagarjuna12.nag.some@vm.com" & @CRLF & _
"nagarjuna12.nag.somenagarjuna12.nag.some@vm.co.uk" & @CRLF & _
"a.b@a.c" & @CRLF & _
"1.2@3.4" & @CRLF & _
"-.-@-.-" & @CRLF & _
"...@a.c" & @CRLF & _
".@a.c" & @CRLF & _
"..@...." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")