#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(.*?)/(.*?),now\s(.*?)\s(.*?)\s"
Local $sString = "usbmuxd/kali-rolling,now 1.1.0-2+b1 amd64 [installed,automatic]" & @CRLF & _
"usbutils/kali-rolling,now 1:007-4 amd64 [installed]" & @CRLF & _
"util-linux/kali-rolling,now 2.28-6 amd64 [installed]" & @CRLF & _
"uuid-runtime/kali-rolling,now 2.28-6 amd64 [installed,automatic]" & @CRLF & _
"va-driver-all/kali-rolling,now 1.7.1-2 amd64 [installed,automatic]" & @CRLF & _
"vboot-kernel-utils/kali-rolling,now 0~R52-8350.B-1 amd64 [installed,automatic]" & @CRLF & _
"vboot-utils/kali-rolling,now 0~R52-8350.B-1 amd64 [installed,automatic]" & @CRLF & _
"vdpau-driver-all/kali-rolling,now 1.1.1-3 amd64 [installed,automatic]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")