import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)/(.*?),now\\s(.*?)\\s(.*?)\\s";
final String string = "usbmuxd/kali-rolling,now 1.1.0-2+b1 amd64 [installed,automatic]\n"
+ "usbutils/kali-rolling,now 1:007-4 amd64 [installed]\n"
+ "util-linux/kali-rolling,now 2.28-6 amd64 [installed]\n"
+ "uuid-runtime/kali-rolling,now 2.28-6 amd64 [installed,automatic]\n"
+ "va-driver-all/kali-rolling,now 1.7.1-2 amd64 [installed,automatic]\n"
+ "vboot-kernel-utils/kali-rolling,now 0~R52-8350.B-1 amd64 [installed,automatic]\n"
+ "vboot-utils/kali-rolling,now 0~R52-8350.B-1 amd64 [installed,automatic]\n"
+ "vdpau-driver-all/kali-rolling,now 1.1.1-3 amd64 [installed,automatic]\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}