const regex = /[\W_]+/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\W_]+', 'gu')
const str = `Úm Titulo`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);