$re = '/^5((\d)(?!\2)\d)\1{3}$/m';
$str = '261616161
561616161
555555555
532323232
512312312
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);