package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0?7[4-9]{1}[0-9]{8}$`)
var str = `07901611249
7901611249
7812304777
7812345678
7901123456
07901234567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}