using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\*+.*\*+$\n)(?:.*\n)+?(?=^\*+.*\*+$\n)";
string input = @"********** Field #1 **********
Content inside Field #1
More content
********** Field #2 **********
Content inside Field #2
More content
********** Field #2 **********
Content inside Field #2
More content";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}