$re = '/^[A-Z](?:[\doO] ?){4}[\doO]$/m';
$str = 'R20209
R4 01 08
R5 0801';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);