using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])\.){3}(\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])\b";
string input = @"192.168.1.1
256.1.0.255
0.0.0.0
255.255.255.255
009.009.009.009
109.109.9.0
55.255.255.255
0.99.199.249
0.19.199.255
A.99.19.199.255.100.0.0.255
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}