import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((\\d|[1-9]\\d|1\\d\\d|2[0-4]\\d|25[0-5])\\.){3}(\\d|[1-9]\\d|1\\d\\d|2[0-4]\\d|25[0-5])\\b";
final String string = "192.168.1.1\n"
+ "256.1.0.255\n"
+ "0.0.0.0\n"
+ "255.255.255.255\n"
+ "009.009.009.009\n"
+ "109.109.9.0\n"
+ "55.255.255.255\n"
+ "0.99.199.249\n"
+ "0.19.199.255\n"
+ "A.99.19.199.255.100.0.0.255\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}