#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=[>])\s+(?=[<])"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html>" & @CRLF & _
"<body>" & @CRLF & _
" <h1>My Test Heading</h1>" & @CRLF & _
" <a href>text1 text2</a>" & @CRLF & _
" <% testfunction() %>" & @CRLF & _
" <p>My Test paragraph.</p> " & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)