re = /(?<=[>])\s+(?=[<])/
str = '<!DOCTYPE html>
<html>
<body>
<h1>My Test Heading</h1>
<a href>text1 text2</a>
<% testfunction() %>
<p>My Test paragraph.</p>
</body>
</html>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result