#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?siU)\[video=youtube_share;([^\]]+)\]([^\[]+)\[\/video\]"
Local $sString = "[video=youtube_share;4cECcwNXMRM]http://youtu.be/4cECcwNXMRM[/video]"
Local $sSubst = "[media=youtube]\1[/media]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)