# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(APP\d{1,5})\w*|\w+\s*/$1/gm;t' <<< "APP00001Was APP00002TEST APP00003Blah blah APP00004 Apple APP11112OrANGE APP
"