// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(APP\d{1,5})\w*|\w+\s*").unwrap();
let string = "APP00001Was APP00002TEST APP00003Blah blah APP00004 Apple APP11112OrANGE APP
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}