$re = '/^\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\/\d{2}( \d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})?(, \d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\/\d{2}( \d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})?)*$/';
$str = '213.233.34.12/30 1.2.3.4, 213.233.34.12/30 1.2.3.4';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);