package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)DeviceXYZ.+$`)
var str = `Building1-Lab1-DeviceABC1
Building1-Lab1-DeviceABC2
Building1-Lab1-DeviceXYZ1
Building1-Lab2-DeviceABC1
Building1-Lab2-DeviceABC2
Building1-Lab2-DeviceXYZ1
Building2-Lab1-DeviceABC1
Building2-Lab1-DeviceABC2
Building2-Lab1-DeviceXYZ1
Building2-Lab2-DeviceABC1
Building2-Lab2-DeviceABC2
Building2-Lab2-DeviceXYZ1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}