use strict;
my $str = 'build: message
fix(scope): message
π₯message
feat: ABC-123 message
feat: message
β¨: message
feat : ABC-123 message
feat!: message
feat(scope)!: message
feat(scope-scope)!: message
feat(scope scope)!: message
feat(scope): ABC-123 message
feat(scope): message
feat(scope): ABC-123 message
feat(scope-scope): ABC-123 message
feat(scope scope): ABC-123 message';
my $regex = qr/^((build|chore|ci|docs|fix|perf|refactor|revert|style|test)(\([\w-]*\))?:|[π¨β‘οΈπ₯πποΈππππβ
ποΈπππ¨π§πβ¬οΈβ¬οΈππ·πβ»οΈββπ§π¨πβοΈπ©βͺοΈππ¦οΈπ½οΈπππ±βΏοΈπ‘π»π¬ποΈπππ₯πΈποΈπ±π€‘π₯ππΈβοΈποΈπ·οΈπ±π©π₯
π«ποΈππ©Ήπ§β°οΈπ§ͺππ©Ίπ§±π§βπ»πΈπ§΅π¦Ί])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}