import re
regex = re.compile(r"(^([a-z][a-z_]*)(/([A-Z][a-z_]*)){,1}$)|(^[A-Z][a-z_]*$)", flags=re.MULTILINE)
test_str = ("hallo\n"
"hallo_x\n"
"Hallo\n"
"Hallo_x\n"
"hallo/Welt\n"
"hallo_x/Welt\n"
"hallo/Welt_y\n"
"hallo_x/Welt_y\n\n"
"hallo_X\n"
"hallo/welt\n"
"hallO/Welt\n"
"hallo/WelT\n"
"Hallo/Welt\n"
"hallo_x/Welt_Y\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")