// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^([a-z][a-z_]*)(/([A-Z][a-z_]*)){,1}$)|(^[A-Z][a-z_]*$)").unwrap();
let string = "hallo
hallo_x
Hallo
Hallo_x
hallo/Welt
hallo_x/Welt
hallo/Welt_y
hallo_x/Welt_y
hallo_X
hallo/welt
hallO/Welt
hallo/WelT
Hallo/Welt
hallo_x/Welt_Y
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}