package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\)>\u001E01\u001D[0-9]{2}[0-9A-Z ]{6}\u001D[0-9]{3}\u001D[0-9]{3}\u001D.+`)
var str = `[)>01961A2B3C1241231Z00ETC
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}