$re = '/([a-zA-Z! ,;“”.\-:]+(\n|$)){3}/';
$str = 'Hello World!The decision about what to put into your paragraphs begins with the germination of a seed of ideas; this “germination process” is better known as brainstorming.
There are many techniques for brainstorming; whichever one you choose, this stage of paragraph development cannot be skipped.
Building paragraphs can be like building a skyscraper: there must be a well-planned foundation that supports what you are building.
Any cracks, inconsistencies, or other corruptions of the foundation can cause your whole paper to crumble.
The decision about what to put into your paragraphs begins with the germination of a seed of ideas; this “germination process” is better known as brainstorming.
There are many techniques for brainstorming; whichever one you choose, this stage of paragraph development cannot be skipped.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);