import Foundation
let pattern = #"([a-zA-Z! ,;“”.\-:]+(\n|$)){3}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Hello World!The decision about what to put into your paragraphs begins with the germination of a seed of ideas; this “germination process” is better known as brainstorming.
There are many techniques for brainstorming; whichever one you choose, this stage of paragraph development cannot be skipped.
Building paragraphs can be like building a skyscraper: there must be a well-planned foundation that supports what you are building.
Any cracks, inconsistencies, or other corruptions of the foundation can cause your whole paper to crumble.
The decision about what to put into your paragraphs begins with the germination of a seed of ideas; this “germination process” is better known as brainstorming.
There are many techniques for brainstorming; whichever one you choose, this stage of paragraph development cannot be skipped.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)