package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`CN\=(?<LastName>[^\\]*)\\,\s(?<FirstName>[^,]*),`)
var str = `CN=LastName\, FirstName,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}