using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[1-31].[1-12]";
string input = @"13.11.1986
01.01.1999
31.12.2020
15.06.2000
01.01.1920
############### Not valid ###########################
31.12.1919
12.13.1985
1.1.2005
1.5.86
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}