#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)span id="(.*)" style="width:0px;"> *<\/span>.*?-(.*)"
Local $sString = "<p><span id="XL" style="width:0px;"> </span>XL - <a class="external text" href="https://w.amazon.com/index.php/Amazon%20XL%20-%203P%20Heavy%20Bulky%20with%20Services" rel="nofollow"</p>zon XL</a>, aka Unified Heavy/Bulky with Services" & @CRLF & _
"<p><span id="XLR" style="width:0px;"> </span>XLR - AB UX Leadership Review (<a class="external text" href="https://quip-amazon.com/Q0MxAQlIvbrR" rel="nofollow">1</a> <a class="exter</p>text" href="https://quip-amazon.com/dVPrAHLgg2hJ" rel="nofollow">2</a> <a class="external text" href="https://quip-amazon.com/dVPrAHLgg2hJ#bNS9CAAGh1S" rel="nofollow">3</a>)" & @CRLF & _
"</p>span id="XML" style="width:0px;"> </span>XML - <a class="external text" href="http://en.wikipedia.org/wiki/XML" rel="nofollow">Extensible Markup Language</a>" & @CRLF & _
"</p>span id="XPF" style="width:0px;"> </span>XPF - Cross Platform" & @CRLF & _
"</p>span id="XRD" style="width:0px;"> </span>XRD - Cross-Functional Response Document" & @CRLF & _
"</p>span id="XRP" style="width:0px;"> </span>XRP - Cross-Region Peering" & @CRLF & _
"</div><h2><span class="mw-headline" id="Y">Y</span></h2>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")