# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"span id=\"(.*)\" style=\"width:0px;\"> *<\/span>.*?-(.*)"
test_str = ("<p><span id=\"XL\" style=\"width:0px;\"> </span>XL - <a class=\"external text\" href=\"https://w.amazon.com/index.php/Amazon%20XL%20-%203P%20Heavy%20Bulky%20with%20Services\" rel=\"nofollow\"</p>zon XL</a>, aka Unified Heavy/Bulky with Services\n"
"<p><span id=\"XLR\" style=\"width:0px;\"> </span>XLR - AB UX Leadership Review (<a class=\"external text\" href=\"https://quip-amazon.com/Q0MxAQlIvbrR\" rel=\"nofollow\">1</a> <a class=\"exter</p>text\" href=\"https://quip-amazon.com/dVPrAHLgg2hJ\" rel=\"nofollow\">2</a> <a class=\"external text\" href=\"https://quip-amazon.com/dVPrAHLgg2hJ#bNS9CAAGh1S\" rel=\"nofollow\">3</a>)\n"
"</p>span id=\"XML\" style=\"width:0px;\"> </span>XML - <a class=\"external text\" href=\"http://en.wikipedia.org/wiki/XML\" rel=\"nofollow\">Extensible Markup Language</a>\n"
"</p>span id=\"XPF\" style=\"width:0px;\"> </span>XPF - Cross Platform\n"
"</p>span id=\"XRD\" style=\"width:0px;\"> </span>XRD - Cross-Functional Response Document\n"
"</p>span id=\"XRP\" style=\"width:0px;\"> </span>XRP - Cross-Region Peering\n"
"</div><h2><span class=\"mw-headline\" id=\"Y\">Y</span></h2>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.