#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<Command>\/(?:.|\n(?:\t| +).)*$)"
Local $sString = "/run attribute 0 "Hello, World!" idNameWoo true [0, 0] minecraft:grass_block run time set 0" & @CRLF & _
"/multiline" & @CRLF & _
" attribute" & @CRLF & _
" 0" & @CRLF & _
" "Hello, World!"" & @CRLF & _
" idNameWoo" & @CRLF & _
" true" & @CRLF & _
" [0, 0]" & @CRLF & _
" minecraft:grass_block" & @CRLF & _
" run time set 0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")