import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<Command>\\/(?:.|\\n(?:\\t| +).)*$)";
final String string = "/run attribute 0 \"Hello, World!\" idNameWoo true [0, 0] minecraft:grass_block run time set 0\n"
+ "/multiline\n"
+ " attribute\n"
+ " 0\n"
+ " \"Hello, World!\"\n"
+ " idNameWoo\n"
+ " true\n"
+ " [0, 0]\n"
+ " minecraft:grass_block\n"
+ " run time set 0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}