// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<Command>\/(?:.|\n(?:\t| +).)*$)").unwrap();
let string = "/run attribute 0 \"Hello, World!\" idNameWoo true [0, 0] minecraft:grass_block run time set 0
/multiline
attribute
0
\"Hello, World!\"
idNameWoo
true
[0, 0]
minecraft:grass_block
run time set 0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}