const regex = /^[+-]?(?:\d+|\d{1,3}(?:,\d{3})*)(?:\.\d*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[+-]?(?:\\d+|\\d{1,3}(?:,\\d{3})*)(?:\\.\\d*)?$', 'gm')
const str = `10000
100,000,000
100,000,000.345345
10000.689
10000000.56
10000000
123,344.456
1234556
123456.124
-1234
-123,456,789
+1234.67
10000,000,000.34534
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}