// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\*[^*]*<br>\*(*SKIP)(*F)|\*([^*]*)\*").unwrap();
let string = "*This is my text<br>* Some other text
*This is my text*<br>Some other text<br>And again *italic*<br>END";
let substitution = "<i>$1</i>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}