$re = '/AS "([^.]+)\.([^.]+)"(?<!AS "[^.]+\.\2"[\s\S]*AS "\1\.\2")(?![\s\S]*AS "[^.]+\.\2")/m';
$str = ' table1.field1 AS "table1.field1",
table2.field2 AS "table2.field2",
table3.field3 AS "table3.field3",
table4.field1 AS "table4.field1",
table4.field1 AS "table5.field5",
table6.field6 AS "table6.field1",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);