import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\d_]+";
final String string = "0001_Smoke_B_B\n"
+ "0002_Smoke_B_B\n"
+ "0012_Smoke_B_B\n"
+ "MA103\n"
+ "MA104\n"
+ "00_00MA105";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}