$re = '/^[\d_]+/m';
$str = '0001_Smoke_B_B
0002_Smoke_B_B
0012_Smoke_B_B
MA103
MA104
00_00MA105';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);