# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*):(.*):(.*):((Fabric & Home Care)):(.*):(.*):(.*):(.*):(critical__c):(.*):((?!null)(?=[\w\ ]{4,}).*):(.*):(.*):(.*):(.*):(.*)$"
test_str = "Tide:Laundry Detergent:Laundry:Fabric & Home Care:Fabric Care:923217:101206518:false:critical__c::ss s:label_coding_insert_missing_incorrect__c:10221:false:false:UNITED STATES-US"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.