import Foundation
let pattern = #"^(.*):(.*):(.*):((Fabric & Home Care)):(.*):(.*):(.*):(.*):(critical__c):(.*):((?!null)(?=[\w\ ]{4,}).*):(.*):(.*):(.*):(.*):(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Tide:Laundry Detergent:Laundry:Fabric & Home Care:Fabric Care:923217:101206518:false:critical__c::ss s:label_coding_insert_missing_incorrect__c:10221:false:false:UNITED STATES-US"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)