using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=""(.*?) target";
string input = @"<a href=""/rss/images/"" target=""_blank""><img src=""/themes/blooper/footer_rss.png"" alt=""RSS"" title=""RSS""></a>,<a href=""https://t.me/blooper"" target=""_blank""><img src=""/themes/blooper/footer_telegram.png?t=1"" alt=""Telegram"" title=""Telegram""></a>,<a href=""https://discord.gg/lit"" target=""_blank""><img src=""/themes/blooper/footer_discord.png?t=1"" alt=""Discord"" title=""Discord""></a>,<a href=""http://blooper.media/""><img src=""/themes/blooper/blooper.png"" alt=""blooper.media"" title=""blooper.media""></a>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}