const regex = /<a href="(.*?) target/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a href="(.*?) target', 'gim')
const str = `<a href="/rss/images/" target="_blank"><img src="/themes/blooper/footer_rss.png" alt="RSS" title="RSS"></a>,<a href="https://t.me/blooper" target="_blank"><img src="/themes/blooper/footer_telegram.png?t=1" alt="Telegram" title="Telegram"></a>,<a href="https://discord.gg/lit" target="_blank"><img src="/themes/blooper/footer_discord.png?t=1" alt="Discord" title="Discord"></a>,<a href="http://blooper.media/"><img src="/themes/blooper/blooper.png" alt="blooper.media" title="blooper.media"></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}