#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)^(\w+)\s+(\w+)\s*,\s*(\w+).*"
Local $sString = "RUIZ JIMENO, ALBERTO ADRIAN => RUIZJIMENOALBERTO" & @CRLF & _
"LÓPEZ FAUSTO, CATALINA DE MIGUEL => LOPEZFAUSTOCATALINA"
Local $sSubst = "\1\2\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)