$re = '/\h*MR\.\h*[A-Z]+/mi';
$str = '<b>MR.SMITH
<b> MR. SMITH';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);