package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mx)^\QThis patch requires:\E\R*
\K
(?:^Patch.+\R)+`)
var str = `This patch requires:
Patch 1.10-1
Patch 1.11-2
Notes:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}