using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:""([^""\\]*(?:\\[\S\s][^""\\]*)*)""|'([^'\\]*(?:\\[\S\s][^'\\]*)*)'|([^'""\\]+)|(\\[\S\s]))";
string substitution = @"$1$2$3$4\n";
string input = @"Telling myself 'you are \'great\' ' and then saying ""thank you"" feels ""a \""little\"" nice""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}