# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(.+?)className='\s*(.+?)\s*'>/<$1className={styles.$2}>/gm;t' <<< "<div className='random_class_name'></div>"