package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<(.+?)className='\s*(.+?)\s*'>`)
var str = `<div className='random_class_name'></div>`
var substitution = "<$1className={styles.$2}>"
fmt.Println(re.ReplaceAllString(str, substitution))
}