import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![\\d@.]*$)\\w+(?:\\.\\w+){0,2}@\\w+(?:\\.\\w+){0,2}$";
final String string = "111@111.111\n"
+ "something@something\n"
+ "some@some.com\n"
+ "some.some.some@heven.co.uk\n\n"
+ "tushar.mahe123@gmail.com\n\n"
+ "some.some.some.some@heven.co.uk.gov";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}