# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*;.*(?:\R|$)//gm;t' <<< "bar
; Foo
baz
;Bar
; aaa aaaaa
Baz"